Insight Properties Not Displaying in EazyBI

When creating an EazyBI report from data in Insight plugin, I am able to see data on Dimensions that are imported (both as Dimensions and as Properties under Measures); however, when I try to view freeform fields imported as Properties, then the data appears blank.

As an example, let’s say I have a database of contacts where each object is a separate contact. Each object has a Jira custom text field for Company Name, and each object will have an Insight object reference for geography (set list of EMEA, APJ, LAR, NAR, etc).

I am importing the Geography as both a Dimension and a Property. I am importing the Company Name as only a Property (not able to select Dimension).

For ROW: I am using Object (tried every hierarchy level, none work)
For COLUMN: I am using “Measures” > “Calculated Members” > “Object Company Name”

This report will return the list of Objects (Contacts) in the database, but will have blank values for the Company name. However if I choose Measures > Calculated Members > Object Geography then it will display the information correctly. So I am only able to display Property data if it is also a Dimension.

Is there a custom MDX that I can use to extract the property? Is there another way that I should be structuring the report in order to see the Object Property information?

Insight has some data structure changes in recent versions. We picked them up and resolved in the latest eazyBI versions. We solved a particular case with text attribute imports as properties in eazyBI version 4.6.0.

We have some updated in eazyBI versions 4.6.1 and 4.6.2 to support recent changes in Insight as well. See our changelog for more details:

Daina /