Single values of the issues does not sum up to the total value shown on the chart

Hi!
I need to be able to track the cycle time, throughput and work in progress for my teams over time. For that I created a report with all three metrics showing month by month over the last 6 months.

My problem is that in the cycle time when I drill through issue the single values do not sum up to the total value shown on the chart.

The total value I get is 121, row count: 13.
When I manually sum up the values for each of the issues I get over 150.

Here is the calculated member I created:
Case WHEN [Measures].[Progress days of resolved issues]>0 THEN
(SUM([Measures].[Progress days of resolved issues],
[Resolution].[Positive Resolutions])
/
([Measures].[Issues resolved],
[Resolution].[Positive Resolutions])
)
END

The Positive Resolutions is just a filter I needed for Cycle Time but not Throughput, hence added to the calculated member. Here is the formula for visibility:

Aggregate({
[Resolution].[Resolved],
[Resolution].[Completed],
[Resolution].[Done],
[Resolution].[Fixed],
[Resolution].[Next Release],
[Resolution].[Released],
[Resolution].[Approved],
[Resolution].[Resolved - No Action Taken],
[Resolution].[In Production],
[Resolution].[Closed]
})

What could be the issue?

Hi Klara,
Welcome to the eazyBI community!

Your formula shows the average (sum of progress days is divided by number of resolved issues)

Case WHEN [Measures].[Progress days of resolved issues]>0 THEN
(SUM([Measures].[Progress days of resolved issues],
[Resolution].[Positive Resolutions])
/
([Measures].[Issues resolved],
[Resolution].[Positive Resolutions])
)
END

When you drill through the issues, you get a list of issues used to calculate the average. For the issue level, this calculation matches issue progress days because the denominator is 1.

If you want to use the “Drill through issue” screen to test whether the average value is correct, you should sum all the values and divide by the row count.

I hope this helps.

Kindly,
Ilze