Drill through worklogs shows more items then schould be

i’ve got a worklog report running. showing logged hours per project and only for the logged in user.

  • Pages: time selection works
  • Pages: Logged by “Eingeloggter User” is a calculated member: with this
[Logged by].[User].getMemberByKey(CurrentUser())
  • Rows is: “Project”
  • Dimension: Logged Hours

When I click on “Drill through worklogs” then it shows too much items, in sum its more than the 33 hours visible in this bar. Here it seems to show all worklogs wor the project for the specified time. (But the header in the table shown, indicates, that total should be 33 hours and only items for the “current user”. but it shows also items from other users.

When I click “Drill through issues” - or “Drill into”, then only items corresponding to the initial selection are shown which in sum are 33 hours.

is this a feature or bug or do i have to configure it differently? clicking on “Drill through worklogs” i would expect to see only the worklogs for the current user, which is the selection for the report?

thanks for your help.

Hi @Matthias_Schindler,

A warm welcome to the eazyBI community.

Thank you for bringing this to our attention. The combination of CurrentUser() and the approach eazyBI takes when drilling through worklogs from the measure “Hours spent” seems to produce this strange behavior.

Currently, I have identified two workarounds. The first uses the Logged by dimension both in report rows and pages, with the “User” level in report rows and the calculated member in the pages.

The other option is updating the Logged by dimension calculated member formula and putting the current statement inside the Aggregate() function. See the suggested formula below:

  [Logged by].[User].getMemberByKey(CurrentUser())

I also registered a bug regarding your finding in our backlog. Currently, I don’t have any estimates as our developers will have a look at it.

Roberts // support@eazybi.com

1 Like

Hi Robert,

great thank for the solution which is totally fine for me. don’t need to wait for the fix of the bug :slight_smile:

Thanks for the quick help.

1 Like