Empty scripted fields in eazyBI having value in JIRA issue

Hi,

we have a custom scripted field in jira and we’re importing it into an eazyBI account as a dimension and property.

The value is calculated properly in the custom field (it has several values in the selected issues), but when we try to use it in reports the values seem to be empty

image

We’ve tried reindexing the project, and also emptied and reimported the whole eazyBI account.

The result is the same.

Any hint?

1 Like

the script field is calculating the value properly for any issue:

Hi!

Could you please also share what advanced settings you have specified for this field in eazyBI?
Also, when you check the issue JSON field (to do that, please modify the URL of the issue replacing browse with rest/api/latest/issue), what does this customfield return? Please post that part of the JSON as well as what is the customfield id so I could further assist you with the settings.

Lauma / support@eazybi.com

Hi @lauma.cirule,

Thank you for your answer!
Here you have the advanced eazyBI settings as well as the JSON code of the custom field:
image

Please let us know if you need more information.
Thank you in advance!

Regards,
Ferran

Hi @fguell!

Truly, everything looks correct - this is just a String field and that is what is defined in eazyBI settings.

It could be though that first there were some other settings for this field and this is why the field did not import. After making changes to field configuration in advanced settings it needs to be un-selected from import and imported all fresh (to make necessary corrections in database structure).

Could you please un-select the field from import and run the import without it. Then select it again and run the import. Let me know if that helped!

Lauma / support@eazybi.com

Hi @lauma.cirule ,

The thing is we did not make any change to the filed configuration, this stopped working one month ago or so. Either way, we wanna try your solution out but I’m afraid I will need more information about how to un-select the field from import and run the import without it.

Thank you in advance!
Ferran

Hi @fguell!

You should go to Source data / Edit Jira source / Custom fields tab and uncheck all import options for this field. Then run the import.
After import has finished, go back to select the fields again and run the import with the fields selected again:

Let me know if that helped!
Lauma / support@eazybi.com

Hi @lauma.cirule,

I’ve followed your steps and when we started the import process, after having imported about 7.000 issues it gave us the following error:

Do you know why is this happening? If you need the error log file please let us know.

Thank you in advance,
Ferran

Hi @fguell!

It seems that eazyBI has detected incorrect configuration for local Jira REST API requests. Please send eazyBI log files and Jira configuration file ‘conf/server.xml’ from Jira installation directory to our support email support@eazybi.com.

Best regards,
Janis

Hi @janis.baiza, @lauma.cirule,

We’ve been able to find the solution. The problem was the user we were using to import all the issues. Once we verified the user data, eazyBI import finished successfully and everything seems to be working as expected, so @lauma.cirule your solution worked for us!

Thank you again,
Regards,

Ferran

1 Like