Escape Bracket in Dimension Name

I have the following problem.

I have a dimension in my EazyBI, whose name is

Sistema [nFeed]

I need to set a calculated member for this field, but because of the square brackets, I do not have access to the properties.

Does anyone know how to escape these characters? Any solution to this problem?

I wait, thank you

Square brackets are reserved characters in eazyBI when addressing dimensions. You would like to add one more closing square brackets to the dimension name to address it correctly in the formulas:

[Sistema [nFeed]]]

Daina / support@eazybi.com

1 Like

Thanks Daina, worked correctly

Hi

I am trying to use aggregate ,
But it is not picking up the number since it has a less than character

Aggregate({ [epic Link].[epic].[vps-60789 minor ehancements <120hrs]})

Since I have < in the value it is not picking up.

Can somehelp to resolve the issue.

Thanks and Regards,
Anand Lourdes

Hi @anand_ignatius,

In this case special character “>” is not a problem. The calculated member didn’t work as expected because of an incomplete epic name. The member name consists of dimension name, parent name from each hierarchy level (if any), and member name itself. Your example is missing the project name of an epic issue. The epic name might look more like this:

Aggregate({ 
  [Epic Link].[<VPS project name>].[VPS-60789 minor ehancements <120hrs] 
})

​When in doubt on the correct member name, eazyBI can help you by telling ahead. One option to get the exact member name is to use autocomplet when writing the calculation. Another option is to bookmark the epic first in the report. And when writing the calculation, pick the bookmarked member from the right side of the MDX formula editor.

For more details on the member name conventions and how to work with autocomplete, see here:
https://docs.eazybi.com/eazybijira/analyze-and-visualize/calculated-measures-and-members

Best,
Zane / support@eazyBI.com

Is there a way to escape characters like this - “Android - :banana:Minions​:banana:”? (see image)
Screen Shot 2020-10-06 at 10.23.54 AM

This is the name of a board in my Jira. When I’m creating a calculated member the board appears in autocomplete after typing “[Sprint].[” but when I try to save the member I get errors.

Any suggestions will be very much appreciated. Thanks!

-jj

Hello,

I’m trying to escape these dimension members below in screenshot. I am unable to escape the [] inside if the dimension member names.

Can you give me a hand with that? I’ve tried quotes, putting ]]],],]] on the end…

Thanks!

Was able to figure it out.

1 Like