Escape Jira Board names in MDX?

Is there a way to escape a Board name that has non-printable characters in it?
We have a board with the name “Minions” with an icon of a banana on either side, like so:
Screen Shot 2020-10-15 at 5.00.32 PM

Notice that the autocomplete finds it and allows me to select it without a problem but when I go to update the member I get this:
Screen Shot 2020-10-15 at 5.02.04 PM

Any ideas, or am I going to have to convince this team who, apparently, are very enamored with their bananas, to change their board name?


You would like to make sure the eazyBI database supports a particular character set. For example, on PostgresSQL the specific characters usage in reports, addressing in calculated members using autocomplete and bookmarked members worked as expected. We used the latest version for the verification of those scenarios.

You would like to check if there are no other impacts here. Emoji of banana in HTML is represented via “&#x1f34c”. However, the error message addresses “&#xd83c” and it seems some space.

You can check if the formula itself does not contain some specific symbols within the code. For example, some extra spaces, extra new lines, etc. If you are using some copied (copy>paste) formula it might contains those symbols. You can retype it and check if it works.

Daina /

1 Like

Thanks for the information, Daina. I took the easy way out and had the team rename their board!
But this is good information to use if I run into this again down the road.