How to export a table report all expanded


I have some table reports that show all the issues of one or more Jira projects, with a hierarchy Epic -> Story -> Sub-taks.
When I export one of those reports to EXCEL, it shows the data as they are shown in the screen: if I have expanded only one Epic - Story - Sub-task, it would appear in all it details but not the rest of the issues recovered by the report.
Is there any way to expand and collapse all the issues hierarchy in the report before it’s exported?

Thanks & Regard


There are at least two ways to expand report till sub-task level.
Please choose the one you prefer
See two attached gifs.

Martins / eazyBI team

Hello Martins

This gifs are very useful, thanks a lot. But my problem is when the report is included in an eazyBI dashboard and the user only have “Dashboards viewer” role.

Is there any way from a dashboard to expand the report?



This feature (to expand all) is not available from dashboard view.
You can expand all members at the same time only via “Analyze” view when creating reports.
The only way would be expanding members by clicking on each member or create a new report which is already expanded.

Martins / eazyBI

Hello again,
I’ve tried these two options and it worked with a normal size report, but now I have a big report and the option “expand all” doesn’t work fine.
As you can see in the attached image:

we need to report the hours spent by Parent, Sub-task, Logged, and by Worklog date.
The problem is that there are too many rows and the report doesn’t show them from the begining. Scrolling is needed and then not all the Parents appear expanded, not even when clicking on “Collapse all” - “Expand all”.
Is there any other option we can implement?
Best regards


Try forcing the “Sub-task” level from the “Issue” dimension menu “All hierarchy level members”.
That should open all sub-tasks in the report.

Martins / eazyBI

Hello @martins.vanags
Thanks for your answer.
The inconvenience of this option is that we need to have the parents in the report in order to aggregate the Hours spent, and they won’t appear on the report.
Is there any other option?
Best regards.


You can force the “Parent” level then, but that would load the first 1000 parents in the report expanded ( if you select “Expand all” from the dimension menu).
The rest of the parents won’t be expanded automatically in the report.
There is not much else you can do in such a layout.

Martins / eazyBI


Thanks for your quick answer. We’ll try another approach.