Import failed: org.postgresql.util.PSQLException: ERROR: invalid input syntax for type numeric: "(none)"

I have this error when import values to custom decimal diemnsion
“import failed: org.postgresql.util.PSQLException: ERROR: invalid input syntax for type numeric: “(none)””

Hi @nadir!

This error is likely when you try to import some dimension with string type as a numerical value.
Then eazyBI would import empty members as (none) and try to convert it to the numerical value resulting in such an error.

Please tell me the custom field type in Jira and if you use any advanced settings to define the field in eazyBI.

Lauma /

Thanks, yeah it is the case but how to fix it ?

Hi @nadir,

To find the best way to fix this, please let me know the following -

Lauma /

Hi @lauma.cirule
Thanks and sorry for did not answer your question.
Below advanced settings of the dimension
name = “Decimal Dimension”
data_type = “decimal”
dimension = true
I extract the value for column of grdi table customfield.

Hi @nadir,

Thank you!
After updating the settings of any field, please make sure to

  1. unselect it from the import and run the import without it. This will delete any database configuration for it.
  2. Then select it for import again and run the import.

If you do this, do you still get an error?
In that case, I believe the problem is not with the “Decimal Dimension” definition but its usage further in the Table Grid settings. So please provide those or any other place where customfield_dimdec is referenced in advanced settings.

Lauma /


Hi @lauma.cirule
Thanks for your precious help, i will try it later.

1 Like

Hi @lauma.cirule ,

I am facing the same issue in my project. I am trying to import a measure ‘CPS’ as dimension and tried with the option you have specified.

  1. added the custom field advanced settings as ‘string’ data type .
  2. Imported once without this column and once by adding it back.

the import is successful but the issue is i got the only ‘none’ value in that dimension and all the other values were not displayed when i placed the ‘cps’ column as row.

Is there any other additional checks that i need to do?

Hi @lauma.cirule ,

I think i found the issue. As i added new row field existing calculation got an issue and i added this to default column list and it got resolved

1 Like

Hello, how do I identify the position?

Issue HD-4197 import failed: org.postgresql.util.PSQLException: ERROR: invalid input syntax for type numeric: “(none)” Position: 5132

It seems you are importing the field with a data type string into some numeric column in the database.

Please detect the field making the problem.

Then you would like to make sure the imported data matches the eazyBI data structures in the database and the value can be successfully transferred from one data type to another.

In this case, the field value is string, but data type in the database is a numeric. You have two scenarios on how to fix this:

  1. Modify the value during import to make sure it is numeric. You can use JavaScript code.
  2. Change the data type for the field in the database. On Cloud and starting with version 6.6. you would like to edit the custom field options and set the data type string. Run the import. Import will detect changes for the import options and change the data type of the field to specified one.

If the above cases do not help, you would like to run the double import to fix the field import options so that the defined options match database structures:

  1. Please deselect the custom field from import options (any selection), save import options and run an import. This import should delete any data structures for this custom field.
  2. Please select the custom field back for import. Save import options and run an import. This import should create new data structures for your custom field.

Daina /

1 Like