Import failed: org.postgresql.util.PSQLException: ERROR: invalid input syntax for type numeric: "(none)"

Hi,
I have this error when import values to custom decimal diemnsion
“import failed: org.postgresql.util.PSQLException: ERROR: invalid input syntax for type numeric: “(none)””
regards,

Hi @nadir!

This error is likely when you try to import some dimension with string type as a numerical value.
Then eazyBI would import empty members as (none) and try to convert it to the numerical value resulting in such an error.

Please tell me the custom field type in Jira and if you use any advanced settings to define the field in eazyBI.

Lauma / support@eazybi.com

@lauma.cirule
Thanks, yeah it is the case but how to fix it ?

Hi @nadir,

To find the best way to fix this, please let me know the following -

Lauma / support@eazybi.com

Hi @lauma.cirule
Thanks and sorry for did not answer your question.
Below advanced settings of the dimension
[jira.customfield_dimdec]
name = “Decimal Dimension”
data_type = “decimal”
dimension = true
separate_table=true
I extract the value for column of grdi table customfield.

Hi @nadir,

Thank you!
After updating the settings of any field, please make sure to

  1. unselect it from the import and run the import without it. This will delete any database configuration for it.
  2. Then select it for import again and run the import.

If you do this, do you still get an error?
In that case, I believe the problem is not with the “Decimal Dimension” definition but its usage further in the Table Grid settings. So please provide those or any other place where customfield_dimdec is referenced in advanced settings.

Lauma / support@eazybi.com

1 Like

Hi @lauma.cirule
Thanks for your precious help, i will try it later.

1 Like

Hi @lauma.cirule ,

I am facing the same issue in my project. I am trying to import a measure ‘CPS’ as dimension and tried with the option you have specified.

  1. added the custom field advanced settings as ‘string’ data type .
  2. Imported once without this column and once by adding it back.

the import is successful but the issue is i got the only ‘none’ value in that dimension and all the other values were not displayed when i placed the ‘cps’ column as row.

Is there any other additional checks that i need to do?

Hi @lauma.cirule ,

I think i found the issue. As i added new row field existing calculation got an issue and i added this to default column list and it got resolved

1 Like