Importing text/string custom Jira field as a measure

So I have a question similar to I want to enable import as measure for a custom filed in eazyBI but the example answer there was for a number, not text/string and I don’t think is applicable?

I have a custom Jira field which is a Select List. The default import offers dimensions/property but I need to import as a measure. This seems similar to the dimension example here: Additional data import into Jira Issues cube.

Here is my current advanced settings code:

# Support for "Field One" as a measure
data_type = "text"
measure = true
separate_table = true

When I look at import settings after this that “Field One” now shows up with a checkbox for measure rather than just dimension/property. But all imports fail with:

2022-05-23 14:15:52 -0400 ERROR: [application_import 16] account 11 : perform_import failed with SourceApplication::ImportError: Cannot import 'string/text' type custom field 'Field One' as measure

I’ve tried turning the field off completely, importing (successfully), then enabling it again. I’ve also tried without the separate table option and with text and string options.

What is needed to get this field to import as a measure?

Hi Tim,

This community post you refer to (I want to enable import as measure for a custom filed in eazyBI - #2 by gerda.zandersone) explains how the single select filed with numeric values can be created as a measure in eazyBI.

The idea of the Javascript code is to protect the select list values from being not numeric since otherwise the field cannot be imported as a measure and will throw the error you have reached.

All the fields by default are imported also as properties and can be referred to at the Issue level like [Measures].[Issue Field One].

Janis, eazyBI support