Jira scripted custom field with multiple dimensions

Hi, I’m trying to script a multi-dimensional field but cannot quite get it to show values in the report table.
I’d like to return values by time and user dimension. Just using multiple_dates (i.e. just the time dimension) worked and showed values, but now with multiple_dimensions the report table stays empty (empty cells), no matter if I add a row/column of Assignee or not.

What am I doing wrong here?

name = “User Times per Day”
data_type = “decimal”
measure = true
multiple_dimensions= [ “Time”, “Assignee” ]
split_by = “,”
javascript_code = ‘’’
issue.fields.customfield_user_times_per_day = “2020-01-01,admin,1\n2020-01-01,foo,3\n2020-01-02,admin,5\n2020-01-02,foo,2”

Hi @ulrich.hobelmann
Just tried the same Javascript on my sandbox and it works as expected when using “Assignee” and “Time” dimensions.

Try reimporting the field again
Perhaps it won’t update the script from the first attempt. Full reimport might help!

Martins / eazyBI

Hi Martins, thanks for the reply. I now got the field working. Is there a list somewhere which Dimensions are valid to use in such a field?

We are trying to filter by Tempo Team (or rather: “Logged by Team”), but EazyBI says those are not standard dimensions we can use (import runs into an error).

There is no such list.
Most of predefined dimensions (imported out of the box) should be available for such additional import.
The tricky part is custom field dimensions and fields imported as dimensions from additional integrations (apps like Tempo).
In the case of Tempo Team, it is saved differently in the eazyBI database and therefore it won’t support additional measure import.

Martins / eazyBI