Query execution timeout of 60 seconds reached

Hello - I am trying to create a report that contains 6 rows, 1 page for the year, and 2 columns.

The plan is to export it to a csv file format so I can do further analysis of the data. It works with 5 rows and 2 columns. When I add the 6th row and expand All Users to list the Logged by individuals it times out.

I am new to eazyBI. Should I be doing this another way or do I need to increase the timeout parameter.

It is under Larry-Ready for Production and the report name is My Team Requests test.

Any help would be greatly appreciated.

Hi,

You should put the following into the EazyBI config. You’ll need a Jira Sysadmin to do this for you:

[mondrian.rolap]
queryTimeout = 120

120 is the # in seconds. Change it to whatever you deem necessary

Hope this helps.

– Malik Graves-Pryor

Hi Malik -

Need a little more help. I have eazyBI for Jira Cloud. Version: 3.2.1-AC

I am not sure if I have Sysadmin capabilities or not. Where exactly do I go to make the change.

I went under eazyBI and clicked on Settings and found Advanced settings.

Is this where I insert it? If so, Can I insert the code anywhere? Once I Update advanced setting does it instantly work?

Advanced setting
[jira.customfield_10836]
data_type = “string”
dimension = true

[jira.customfield_sourcecode]
name = “Source Code”
data_type = “integer”
measure = true
javascript_code = ‘’’
{issue.fields.customfield_sourcecode = 3;}
‘’’

[jira.customfield_servicecode]
name = “Service Code”
data_type = “integer”
measure = true
javascript_code = ‘’’
if ( issue.fields.customfield_10821 ) {
if( issue.fields.customfield_10821.value == “Account Analyst” ){
issue.fields.customfield_servicecode = 5751;
}
else
if( issue.fields.customfield_10821.value == “Programmer” ){
issue.fields.customfield_servicecode = 5744;
}
else
if( issue.fields.customfield_10821.value == “Contractor” ){
issue.fields.customfield_servicecode = 5744;
}
}
‘’’
[jira.customfield_lineitem]
name = “Line Item”
data_type = “integer”
measure = true
javascript_code = ‘’’
if ( issue.fields.customfield_10821 ) {
if( issue.fields.customfield_10821.value == “Account Analyst” ){
issue.fields.customfield_lineitem = 1;
}
else
if( issue.fields.customfield_10821.value == “Programmer” ){
issue.fields.customfield_lineitem = 25;
}
else
if( issue.fields.customfield_10821.value == “Contractor” ){
issue.fields.customfield_lineitem = 25;
}
}
‘’’

Yep just put it anywhere in there as a separate section. It takes effect immediately.

Hope this helps!

– Malik Graves-Pryor

I made the change.

As you can see I changed it to 180. it still times out and says “Query execution timeout of 60 seconds reached.” Shouldn’t it say …180 seconds reached? Did my change take hold?

Advanced setting
[mondrian.rolap]
queryTimeout = 180

[jira.customfield_10836]
data_type = “string”
dimension = true

[jira.customfield_sourcecode]
name = “Source Code”
data_type = “integer”
measure = true
javascript_code = ‘’’
{issue.fields.customfield_sourcecode = 3;}
‘’’

[jira.customfield_servicecode]
name = “Service Code”
data_type = “integer”
measure = true
javascript_code = ‘’’
if ( issue.fields.customfield_10821 ) {
if( issue.fields.customfield_10821.value == “Account Analyst” ){
issue.fields.customfield_servicecode = 5751;
}
else
if( issue.fields.customfield_10821.value == “Programmer” ){
issue.fields.customfield_servicecode = 5744;
}
else
if( issue.fields.customfield_10821.value == “Contractor” ){
issue.fields.customfield_servicecode = 5744;
}
}
‘’’
[jira.customfield_lineitem]
name = “Line Item”
data_type = “integer”
measure = true
javascript_code = ‘’’
if ( issue.fields.customfield_10821 ) {
if( issue.fields.customfield_10821.value == “Account Analyst” ){
issue.fields.customfield_lineitem = 1;
}
else
if( issue.fields.customfield_10821.value == “Programmer” ){
issue.fields.customfield_lineitem = 25;
}
else
if( issue.fields.customfield_10821.value == “Contractor” ){
issue.fields.customfield_lineitem = 25;
}
}
‘’’

Try restarting your cloud instance of jira, or at the very least disabling and then reenabling eazybi cloud plugin.

– Malik Graves-Pryor

Do you have instructions on how to do this?

Go to the Jira admin settings and open the Universal Plugin Manager. You’ll see an entry for EazyBI and can disable and reenable it there.

https://confluence.atlassian.com/adminjiracloud/managing-add-ons-776830283.html#Managingapps-TheUniversalPluginManager for more detailed instructions. If you’re still having trouble you should contact your Jira sysadmin to assist.

Hope this helps.

– Malik Graves-Pryor

We are new to both Jira and eazyBI. I would be as close to an sysadmin for our company.
Please see the attached. My options are to unsubscribe. Seems a bit drastic to unsubscribe to make this work. Any other options?

Ah, queryTimeout is a configurable setting that only applies to EazyBI for Jira Server where the child process has been enabled. As you’re using a cloud instance it will not apply to you.

https://docs.eazybi.com/eazybijira/set-up-and-administer/set-up-and-administer-for-jira-server/advanced-settings#Advancedsettings-Increasequerytimeout

I did some reading in the EazyBI docs and it doesn’t appear that there is any way to change the timeout for cloud instances. You may want to email support@eazybi.com to see if there’s anything that is not documented that you might be able to use. That has cropped up a few times in my travels with EazyBI over the years.

Hope this helps.

– Malik Graves-Pryor

Interesting… Thanks for all your help Malik!

I will talk to eazyBI Support.

Good luck

– Malik Graves-Pryor

Hi,

@malikgp thanks for the idea, but increasing the query timeout would not be possible when eazyBI is used for Jira Cloud.

@lwilson185 you should rather focus on improving the report to make the query as simple as possible.
In this case, I would recommend enabling the " Nonempty " cross-join in your report when multiple dimensions are used in rows. That would skip query iteration through empty members.

Martins / support@eazybi.com

Also, to help explain for others that may be reading this channel:

The 60 second timeout is set to that value for a reason. If you change it to a higher number, people can lazily write inefficient queries that can take a large amount of server and db resource to execute.

60 seconds should normally be enough to write queries. It forces you to reevaluate what you are trying to show and to simplify it. Most times this is a very useful prompt and results in better queries.

Granted though that there are some times when you just wish you could have longer for a particularly complex query. Martins, is it possible maybe to have a parameter for complex queries where we specifically allow it a longer timeout?

Hi @markg

Thank you for the feedback.
At the moment there is no such feature to increase the timeout for specific report or query only. This has to be done for the whole eazyBI instance.
But that is very great idea.

Martins / eazyBI