Received HTTP 502 error when requesting REST


I am trying to add a source data from a REST API end point. This rest api end point is public and there is no authentication involved. I can visit the api end point via a browser - firefox and chrome and can see the valid json response.

When I try the same thing via easy BI, I get an error. Can you please help. The configuration and the error screenshot is below. I tried adding headers but its of no use.

When I inspected the console, I see 500 error. Tried with different headers too but still no luck. Please help.


Hi, Azeez

To be sure that there is no authentication involved, could you please open the URL in the private browsing session?
Usually, 502 error means that there is a problem between a caller and the source server, this time eazyBI and the REST API source.
To help you more with the problem, please send us eazyBI log files ( ) to or upload them on

Best regards,

Thanks Janis.

Tried to access the REST API endpoint via the browse incognito window and it works fine. Can get a successful response. Tried with both firefox and chrome. I don’t see a problem there.

I see that there is a setting in the configuration file which might be a problem.
Advanced Settings - SSRF

Currently I am checking internally with my admin team if they have enabled it. Once I get the response from them I shall send you the logs. I don’t want to trouble you with logs if we have done some mis-configuration.