Week hierarchy in time dimension

In time dimension you can choose Year/Quarter/Month or Day level of members.
Is there a way to show Week level? When i choose “Weekly / Week” all data disappear :frowning:


The days belong to weeks or months, etc. But as a new month almost always starts in the middle of a week, there is no such clear way of defining which week belongs to which month. For this reason, the Time dimension has two default hierarchies - in one days are grouped by months, in the other by weeks.

The default measures should not disappear when using any of the hierarchies; they are just grouped differently. For calculated measures, you need to make sure you are using the same context as in the report:

  • If you, e.g., [Time].CurrentMember, then it is best to change it to [Time].CurrentHierarchyMember
  • If calculation is created in Time dimension, you need to make sure you are creating it in the correct hierarchy which you can choose from the dropdown next to the new member name

If you have problems with this, please let me know more details of what measures you use and what is the other report context.

Lauma / support@eazybi.com

thank you for your answer. I didn’t know about setting time.weekly in calculated members - i’ll check that, but i’ve tried to use weekly hierarchy in default measures and still no data:

​Thank you for the screenshot, it is helpful to be on the same page while finding out why the report behaves in such a way!

I see you are using Time dimension both on Rows and Pages, but with members selected from different hierarchies - weeks on rows, but filtering from Time default hierarchy Quarter level.
When changing the hierarchy in one place in the Time dimension, it should be changed also in the others for correct report context and measures to show up.

I see your point though! I will bring this case up with my colleagues to discuss if in future we could make the hierarchy change automatic in Page, if done on row.
Lauma / support@eazybi.com

Changing Hierarchy both in pages and rows give expected results! :slight_smile:
Thank you for your help

1 Like