JIRA custom field not accessible in eazyBI reports

Hi we are trying to make a custom field value available in some reports and have looked through and tried many of the solution sin the documentation and community but are not able to get it working.

Some background:
we have a value that is added to an initial user story called DEV estimate which provides the initial estimated value we feel is needed for DEv work. this is then used by our build team as a basis for sprint planning and further broken down into story points on the dev cards. we want to be able to compare these actuals to the original estimated in the DEV estimate but we can’t seem to get the values to populated in the eazyBI tool.

Here is what we have done

We selected “Import as property” for the custom field DEV Estimates (custom field 11714). (that is the only choice - it is a text field)

Under additional options, we have custom JavaScript code that converts it to numeric: issue.fields.customfield_11714=Number(issue.fields.customfield_11714);

test results:

{
“id”: 737648,
“key”: “LINSPAR-2090”,
“fields”: {
“summary”: “xxxxxxxxxxx Fudge Issues”,
“project”: {},
“components”: [],
“issuetype”: {},
“fixVersions”: [],
“versions”: [],
“reporter”: {},
“assignee”: {},
“priority”: {},
“status”: {},
“resolution”: null,
“security”: null,
“created”: “2020-06-01T07:47:26.187-0500”,
“updated”: “2020-06-08T10:17:32.013-0500”,
“duedate”: null,
“resolutiondate”: null,
“timetracking”: {},
“timeoriginalestimate”: 108000,
“timeestimate”: 108000,
“timespent”: null,
“labels”: [],
“worklog”: {},
“customfield_11714”: 9,

},
“properties”: {},
“changelog”: {
“histories”: []
}
}

you can see there is a numeric value there. “customfield_11714”: 9,

When we then try to reference the member as [Measures].[FYE created] but there is no data.

Can anyone help?

Thanks

Hi @gtcl,
As you have discovered eazyBI offers default import options based on a detected custom field type. You could override the custom field definition by adding additional options on how to import the custom field.
Here is a custom field definition example, that overrides default setup and also imports this field as measure (you can check different options here - https://docs.eazybi.com/eazybijira/data-import/custom-fields/advanced-settings-for-custom-fields):

[jira.customfield_NNNNN] 
data_type = "decimal" 
measure = true

Use the Jira custom field ID instead of NNNNN in the definition above.

Add the updated custom field definition to eazyBI advanced settings or ask Jira administrator or eazyBI administrator to do this for you. eazyBI advanced settings are common for all accounts and only Jira/eazyBI administrators have access to the settings.

New setup requires new data structures in a database. You would like to delete old ones and then create new data entries. Please run an import twice after those changes:

  1. Open import options for edit and deselect the custom field from import settings (any selection), save settings and run an import. This import should delete any data structures for this custom field.
  2. Open import options for edit once more and select the custom field back for import. Save settings and run an import. This import should create new data structures for your custom field.

Gerda // support@eazyBI.com

Hi @gerda.zandersone
I used the same advances setting for all text custom fields imported to eazy BI but unfortunately it shows only some values for the fields.

For eg-: I have created a field Department which has 8 values but in eazy BI it brings up only 7.

And for all other imported fields it shows nothing.

Please suggest
URGENT !!

Thanks in advance!

Is there any alternate to it ?

Hi @Ragini ,
For the text field, you should import it as dimension. See the related answer here:

kind regards,
Gerda