Measure related error on EazyBI Dashboards

EazyBI dashboards are showing an Error message like “Report definition contains column measure [Measures].[Issues Sp changed] which is not defined.” kindly help me to resolve this.

Thanks in advance

Hi Raju,

As we resolved this through email, I’ll go ahead and write up the summary here for anyone else that is facing a similar problem.

There is a measure missing in one or more reports.
You can open each report in the dashboard in a new tab and see which report has this missing measure (the report will have the same error).

For these reports (where the error is present), select and deselect any random measure (so that the report thinks that you are making changes) and click the “Save” button for the report so that a new report definition is generated without this missing measure.

This will fix the issue with the missing measure in the report definition.

Cheers!
Nauris

Hi Nauris,

It’s the same error that was you resolved email.

Thank you for your support

Hi @nauris.malitis ,
we are affected by this on many many reports for our Stage-Migration.
Now for live-migration we would like to avoid these manual tasks!

Will this be fixed? What is causing this?
Thanks & BR
Sascha

Hi @s.weber

This is caused by reports which have specific measures selected in them that are later deleted from the account.
Previously, no error was shown for these faulty report definitions, in the newer eazyBI versions, however, the report validator warns that there are some elements missing from the report.
Re-saving each faulty report is the only way how to fix this.

​Let me know if you have any additional questions on this!
​Best regards,
​Nauris

1 Like